LNMP 1.x升级到LNMP 1.4教程及注意事项和多PHP版本使用教程

作者:licess 发布时间:2017年06月1日 分类:常见问题

LNMP 1.x版本基本都可以正常升级到1.4使用1.4的管理脚本和新的功能。

升级管理脚本:wget -c http://soft.vpser.net/lnmp/lnmp1.4.tar.gz && tar zxf lnmp1.4.tar.gz && cd lnmp1.4 && ./upgrade1.x-1.4.sh
有些功能是需要另外升级nginx、php版本或安装多php版本的,下面会进行单独的说明。

新的功能主要是两个添加SSL和多PHP版本选择。

添加SSL:

添加SSL有两种方式可以选择,1是自备证书和key,这个不需要多说,按提示分别填写上证书和key的完整路径和名称。2是使用Let'sEncrypt生成3个月有效期的SSL证书,另外按提示一个邮箱就可以。

已经添加过改域名的http站点,添加https站点直接运行:lnmp ssl add 按提示添加,可以参考新添加教程的提示说明。

新添加虚拟主机按:https://lnmp.org/faq/lnmp-vhost-add-howto.html

注意1:添加的SSL虚拟主机是默认http2的,如果是之前的版本未使用openssl 1.0.2进行编译或者Nginx低于1.9的话,建议升级到1.12.0,使用升级脚本:./upgrade.sh nginx 进行升级。
注意2:如果是对已有主机添加SSL,因为之前的1.3版本默认LNMP的虚拟主机里是禁止 . 开头的隐藏文件及目录的,所以访问http://abc.com/.well-known/acme-challenge/**** 这个链接的话返回403错误,所以必须要将对应虚拟主机配置文件里的
location ~ /\.
{
deny all;
}
这段配置删掉或注释掉或在这段配置前面加上
location ~ /.well-known {
allow all;
}
修改保存后重启nginx。
注意3:https网站里面的js、css、图片等资源的引用必须是https的,如果是http的会提示不安全也没有小绿锁。需要自行修改网站模板、网站内容里的图片等为https连接或者直接使用相对路径引用。


多PHP版本使用教程:
多PHP版本只支持LNMP模式,LNMPA、LAMP模式下不支持!
要使用多PHP先安装多PHP版本,在lnmp1.4源码目录下运行:./install.sh mphp 按提示选择要另外安装的PHP版本,不能多选,只能选一个,要安装多个需要安装完成后再运行前面的安装命令。
已经升级完LNMP管理脚本且已安装好多PHP版本的话,lnmp vhost add 时会在设置完日志名称后提示当前已经存在的PHP版本,按提示的数字选择就可以。

如果已经存在的虚拟主机要更改PHP为指定版本需要修改虚拟主机的配置文件,配置文件为 /usr/local/nginx/conf/vhost/域名.conf ,将里面的include enable-php.conf; 替换为 include enable-php7.1.conf; 前面的7.1为php版本,可以根据自己的需要进行修改,但必须要对应的多php版本已经安装,要不然会提示502错误。

修改后必须要重启nginx,否则无法生效。


如要使用新版里面的PHP模块组件安装工具需要升级一下PHP才能使用新版PHP组件安装工具。

标签: lnmp升级, 升级到lnmp1.4, lnmp升级教程, lnmp升级注意事项

评论已关闭