LNMP一键安装包 V1.5 正式版

作者:licess 发布时间:2018年06月1日 分类:公告


LNMP 1.5正式版一如既往的6.1发布了,提前祝儿童节快乐。1.5版本主要新增加PHP7.2支持、增加Maria DB 10.2、增加无人值守安装、增加多核编译安装、替换问题较多的certbot使用acme.sh不需要过多的依赖生成SSL更丝滑、支持生成泛域名SSL证书、lnmp管理脚本增加pathinfo选项、lnmp.conf中增加PHP模块fileinfo安装选项和Nginx lua模块安装选项、增加一些常用伪静态、Apache 2.4支持到http2、Nginx默认支持stream等功能,增加了一些特殊环境下的适应patch,等等就不一一列举了,可以看lnmp更新记录

LNMP安装教程https://lnmp.org/install.html
问题反馈及使用交流论坛https://bbs.vpser.net/forum-25-1.html
免费泛域名SSL证书生成教程https://lnmp.org/faq/letsencrypt-wildcard-ssl.html
无人值守安装说明https://lnmp.org/faq/v1-5-auto-install.html
打赏捐赠https://lnmp.org/donation.html
VPS推荐https://www.vpser.net/ten-dollars-vps

关于升级到当前版本
低版本的因为涉及到很多程序版本的变动和配置文件的变化,想完整的升级最好是备份数据,卸载后重新安装或重装系统重装。

1.x版本的话在1.5安装包目录下 ./upgrade1.x-1.5.sh 可进行升级lnmp管理脚本及大部分功能,可以使用lnmp 1.5的新功能。除Nginx、PHP、MySQL版本外功能基本都能正常使用,Nginx、PHP可以通过升级脚本进行升级、MySQL只要没问题不建议进行升级。

之前certbot生成的SSL迁移到acme.sh
需要先在1.5安装包目录下 ./upgrade1.x-1.5.sh 升级管理脚本到最新1.5版本,然后再进行升级之前通过certbot生成的SSL证书,在安装包目录下执行:./upgrade1.x-1.5.sh ssl 进行升级,升级过程需要输入域名、网站目录信息,这些信息必须要和配置文件中的一致,不然会升级失败。不确定信息的话可以先cat /usr/local/nginx/conf/vhost/域名.conf,LAMP模式下是 cat /usr/local/apache/conf/vhost/域名.conf 。
没添加过SSL的虚拟主机依然是用lnmp ssl add 命令进行添加。

常用工具

添加、删除虚拟主机及伪静态管理:https://lnmp.org/faq/lnmp-vhost-add-howto.html
泛域名/通配符证书生成教程:https://lnmp.org/faq/letsencrypt-wildcard-ssl.html
PHP缓存优化类组件eAccelerator,xcache,memcached,imageMagick,ionCube、opcache、redis的安装:https://lnmp.org/faq/addons.html

LNMP v1.5 无人值守安装教程

作者:licess 发布时间:2018年03月7日 分类:常见问题


无人值守安装是最近v1.5测试版新增的功能,可以预设好相关参数自动进行安装不需要按提示一个一个的选择适合批量安装部署,欢迎测试并论坛反馈

2018.3.28 update: 添加无人值守命令生成工具 https://lnmp.org/auto.html

下载安装命令和以前基本一样,完整的无人值守安装命令如下(以LNMP模式,默认选项安装MySQL 5.5、MySQL root密码设置为lnmp.org、启用InnoDB、PHP 5.6、不安装内存分配器为例):wget http://soft.vpser.net/lnmp/lnmp1.5beta.tar.gz -cO lnmp1.5beta.tar.gz && tar zxf lnmp1.5beta.tar.gz && cd lnmp1.5 && LNMP_Auto="y" DBSelect="2" DB_Root_Password="lnmp.org" InstallInnodb="y" PHPSelect="5" SelectMalloc="1" ./install.sh lnmp

注意如果缺失参数的话还是会有要求选择缺失选项的提示。

无人值守安装所需的参数及说明如下:

变量名 变量值含义
LNMP_Auto 启用无人值守自动安装
DBSelect 数据库版本序号
DB_Root_Password 数据库root密码(不可为空),不安装数据库时可不加该参数
InstallInnodb 是否安装Innodb引擎,y 或 n ,不安装数据库时可不加该参数
PHPSelect PHP版本序号
SelectMalloc 内存分配器版本序号
ApacheSelect Apache版本序号,仅LNMPA和LAMP模式需添加该参数
ServerAdmin 管理员邮箱,仅LNMPA和LAMP模式需添加该参数

各程序版本对应序号

MySQL版本 对应序号 PHP版本 对应序号 内存分配器 对应序号 Apache版本 对应序号
MySQL 5.1 1 PHP 5.2 1 不安装 1 Apache 2.2 1
MySQL 5.5 2 PHP 5.3 2 Jemalloc 2 Apache 2.4 2
MySQL 5.6 3 PHP 5.4 3 TCMalloc 3
MySQL 5.7 4 PHP 5.5 4
MySQL 8.0 5 PHP 5.6 5
MariaDB 5.5 6 PHP 7.0 6
MariaDB 10.0 7 PHP 7.1 7
MariaDB 10.1 8 PHP 7.2 8
MariaDB 10.2 9
不安装数据库 0

另外再举几个其他例子:


lamp模式不安装数据库、PHP 7.1、不安装内存分配器、Apache 2.4:
wget http://soft.vpser.net/lnmp/lnmp1.5beta.tar.gz -cO lnmp1.5beta.tar.gz && tar zxf lnmp1.5beta.tar.gz && cd lnmp1.5 && LNMP_Auto="y" DBSelect="0" PHPSelect="7" SelectMalloc="1" ApacheSelect="2" ServerAdmin="admin@admin.com" ./install.sh lamp

lnmpa模式安装MariaDB 5.5 密码设为www.vpser.net 并开启InnoDB、PHP 7.2、安装TCMalloc、Apache 2.4:
wget http://soft.vpser.net/lnmp/lnmp1.5beta.tar.gz -cO lnmp1.5beta.tar.gz && tar zxf lnmp1.5beta.tar.gz && cd lnmp1.5 && LNMP_Auto="y" DBSelect="5" DB_Root_Password="www.vpser.net" InstallInnodb="y" PHPSelect="8" SelectMalloc="3" ApacheSelect="2" ServerAdmin="admin@admin.com" ./install.sh lnmpa

如在使用过程中有任何问题可以在论坛反馈

LNMP一键安装包 V1.5 测试版

作者:licess 发布时间:2018年01月8日 分类:公告

LNMP 1.5测试版,主要新增加PHP7.2支持、增加Maria DB 10.2、替换问题较多的certbot使用acme.sh不需要过多的依赖生成SSL更丝滑、lnmp管理脚本增加pathinfo选项、lnmp.conf中增加PHP模块fileinfo选项和Nginx lua模块选项、增加一些常用伪静态、Apache 2.4支持到http2、Nginx默认支持stream等功能。

安装前建议使用screen,执行:screen -S lnmp 后,执行:wget -c http://soft.vpser.net/lnmp/lnmp1.5beta.tar.gz && tar zxf lnmp1.5beta.tar.gz && cd lnmp1.5 && ./install.sh lnmp 请注意最后的参数,需要其他模式就写哪个如lnmpa 或 lamp,./install.sh 不带任何参数默认为LNMP模式。

阅读剩余部分...